Consumer
Products
AquaTrio Vacuuming and Mopping System

AquaTrio Vacuuming and Mopping System

3-in-1 FC7070/01

Troubleshooting

My Philips AquaTrio vacuum cleaner's brushes do not work

This can have several causes. Check all possible causes to do with your appliance in the following order.

1. The lid of the mopping nozzle is not closed properly

Sometimes the lid appears to be properly closed, while in reality it is not. Make sure it is closed properly.

Closing the lid

2. The Active Protection System has been activated

When the Active Protection System has been activated, the brushes do not rotate and no water is applied to the floor.

To reset the Active Protection System:

  1. Switch off the appliance and pull the plug out of the wall socket.
  2. Open the mopping nozzle lid, remove the mopping brush cover and take out the object.
  3. If the active protection system was activated because the mopping brushes are too wet, remove the mopping brushes and squeeze them over the sink.
  4. Place the dry mopping brushes back into the appliance.
  5. Replace the mopping brush cover and close the mopping nozzle lid. Press the mopping nozzle lid to lock it ('click').

If the above solutions did not solve your problem, please contact Philips Consumer Care in your country.

Play Pause
You need Flash to see video.
Click here to download it.

The information on this page applies to the following models: FC7070/01 .

Not what you are looking for?

Did we answer your question?

If not, contact us.