Lumify is compatible with the latest encryption and data security systems and can be made to comply with enterprise data security policies. Read the Lumify System and Data Security document for more information.

Our site can best be viewed with the latest version of Microsoft Edge, Google Chrome or Firefox.